Chris (chgu) wrote in lj_dev,
Chris
chgu
lj_dev

Error on a fresh install

I just set everything up today, and after getting all the modules satisfied, and apache with mod_perl compiled in working, I get this:

Error loading event module 'LJ::Event::JournalNewComment': Base class package "LJ::MemCacheable" is empty.\n

Full error after the cut.

Thu Sep 11 14:36:14 2008] [error] Error loading event module 'LJ::Event::JournalNewComment': Base class package "LJ::MemCacheable" is empty.\n (Perhaps you need to 'use' the module which defines that package first.)\n at /home/lj/cgi-bin/LJ/Poll.pm line 9\nBEGIN failed--compilation aborted at /home/lj/cgi-bin/LJ/Poll.pm line 9.\nCompilation failed in require at /usr/lib/perl5/site_perl/5.8.8/Class/Autouse.pm line 410.\n at /usr/lib/perl5/site_perl/5.8.8/Class/Autouse.pm line 410\nBEGIN failed--compilation aborted at /home/lj/cgi-bin/LJ/Entry.pm line 1219.\nCompilation failed in require at /usr/lib/perl5/site_perl/5.8.8/Class/Autouse.pm line 410.\n at (eval 903) line 2\nBEGIN failed--compilation aborted at /home/lj/cgi-bin/LJ/Comment.pm line 13.\nCompilation failed in require at /usr/lib/perl5/site_perl/5.8.8/Class/Autouse.pm line 410.\n at /usr/lib/perl5/site_perl/5.8.8/Class/Autouse.pm line 410\nBEGIN failed--compilation aborted at /home/lj/cgi-bin/LJ/Event/JournalNewComment.pm line 4.\nCompilation failed in require at (eval 903) line 2.\nBEGIN failed--compilation aborted at (eval 903) line 2.\nCompilation failed in require at /usr/lib/perl5/site_perl/5.8.8/Class/Autouse.pm line 410.\n at /home/lj/cgi-bin/weblib.pl line 20\nBEGIN failed--compilation aborted at /home/lj/cgi-bin/weblib.pl line 20.\nCompilation failed in require at /home/lj/cgi-bin/LJ/NotificationMethod/Email.pm line 8.\nCompilation failed in require at /usr/lib/perl5/site_perl/5.8.8/Class/Autouse.pm line 410.\n at /usr/lib/perl5/site_perl/5.8.8/Class/Autouse.pm line 410\nBEGIN failed--compilation aborted at /home/lj/cgi-bin/LJ/NotificationMethod.pm line 11.\nCompilation failed in require at /usr/lib/perl5/site_perl/5.8.8/Class/Autouse.pm line 410.\n at /home/lj/cgi-bin/ljlib.pl line 23\nBEGIN failed--compilation aborted at /home/lj/cgi-bin/LJ/Subscription.pm line 9.\nCompilation failed in require at /usr/lib/perl5/site_perl/5.8.8/Class/Autouse.pm line 410.\n at /home/lj/cgi-bin/Apache/LiveJournal/Interface/AtomAPI.pm line 15\nBEGIN failed--compilation aborted at /home/lj/cgi-bin/LJ/User.pm line 39.\nCompilation failed in require at /home/lj/cgi-bin/ljlib.pl line 23.\nBEGIN failed--compilation aborted at /home/lj/cgi-bin/ljlib.pl line 23.\nCompilation failed in require at /home/lj/cgi-bin/fbupload.pl line 10.\nCompilation failed in require at /home/lj/cgi-bin/Apache/LiveJournal/Interface/AtomAPI.pm line 15.\nCompilation failed in require at /usr/lib/perl5/site_perl/5.8.8/Class/Autouse.pm line 410.\n at (eval 2) line 1\nBEGIN failed--compilation aborted at /home/lj/cgi-bin/Apache/LiveJournal.pm line 31.\nCompilation failed in require at /home/lj/cgi-bin/modperl_subs.pl line 11.\nBEGIN failed--compilation aborted at /home/lj/cgi-bin/modperl_subs.pl line 11.\nCompilation failed in require at /home/lj/cgi-bin/modperl.pl line 20.\nCompilation failed in require at (eval 2) line 1.\n
Syntax error on line 22 of /usr/local/apache/conf/httpd.conf:
Error loading event module 'LJ::Event::JournalNewComment': Base class package "LJ::MemCacheable" is empty.
(Perhaps you need to 'use' the module which defines that package first.)
at /home/lj/cgi-bin/LJ/Poll.pm line 9
BEGIN failed--compilation aborted at /home/lj/cgi-bin/LJ/Poll.pm line 9.
Compilation failed in require at /usr/lib/perl5/site_perl/5.8.8/Class/Autouse.pm line 410.
at /usr/lib/perl5/site_perl/5.8.8/Class/Autouse.pm line 410
BEGIN failed--compilation aborted at /home/lj/cgi-bin/LJ/Entry.pm line 1219.
Compilation failed in require at /usr/lib/perl5/site_perl/5.8.8/Class/Autouse.pm line 410.
at (eval 903) line 2
BEGIN failed--compilation aborted at /home/lj/cgi-bin/LJ/Comment.pm line 13.
Compilation failed in require at /usr/lib/perl5/site_perl/5.8.8/Class/Autouse.pm line 410.
at /usr/lib/perl5/site_perl/5.8.8/Class/Autouse.pm line 410
BEGIN failed--compilation aborted at /home/lj/cgi-bin/LJ/Event/JournalNewComment.pm line 4.
Compilation failed in require at (eval 903) line 2.
BEGIN failed--compilation aborted at (eval 903) line 2.
Compilation failed in require at /usr/lib/perl5/site_perl/5.8.8/Class/Autouse.pm line 410.
at /home/lj/cgi-bin/weblib.pl line 20
BEGIN failed--compilation aborted at /home/lj/cgi-bin/weblib.pl line 20.
Compilation failed in require at /home/lj/cgi-bin/LJ/NotificationMethod/Email.pm line 8.
Compilation failed in require at /usr/lib/perl5/site_perl/5.8.8/Class/Autouse.pm line 410.
at /usr/lib/perl5/site_perl/5.8.8/Class/Autouse.pm line 410
BEGIN failed--compilation aborted at /home/lj/cgi-bin/LJ/NotificationMethod.pm line 11.
Compilation failed in require at /usr/lib/perl5/site_perl/5.8.8/Class/Autouse.pm line 410.
at /home/lj/cgi-bin/ljlib.pl line 23
BEGIN failed--compilation aborted at /home/lj/cgi-bin/LJ/Subscription.pm line 9.
Compilation failed in require at /usr/lib/perl5/site_perl/5.8.8/Class/Autouse.pm line 410.
at /home/lj/cgi-bin/Apache/LiveJournal/Interface/AtomAPI.pm line 15
BEGIN failed--compilation aborted at /home/lj/cgi-bin/LJ/User.pm line 39.
Compilation failed in require at /home/lj/cgi-bin/ljlib.pl line 23.
BEGIN failed--compilation aborted at /home/lj/cgi-bin/ljlib.pl line 23.
Compilation failed in require at /home/lj/cgi-bin/fbupload.pl line 10.
Compilation failed in require at /home/lj/cgi-bin/Apache/LiveJournal/Interface/AtomAPI.pm line 15.
Compilation failed in require at /usr/lib/perl5/site_perl/5.8.8/Class/Autouse.pm line 410.
at (eval 2) line 1
BEGIN failed--compilation aborted at /home/lj/cgi-bin/Apache/LiveJournal.pm line 31.
Compilation failed in require at /home/lj/cgi-bin/modperl_subs.pl line 11.
BEGIN failed--compilation aborted at /home/lj/cgi-bin/modperl_subs.pl line 11.
Compilation failed in require at /home/lj/cgi-bin/modperl.pl line 20.
Compilation failed in require at (eval 2) line 1.

/usr/local/apache/bin/apachectl start: httpd could not be started


Is this a bug, or am I doing something wrong? I've left the ljconfig.pl file completely default.

Edit: This was fixed this morning(Sept 16th). They were moving a feature from ljcom over to the svn. NOW I have an issue with not being able to view user info.
Tags: *unanswered, server
Subscribe
  • Post a new comment

    Error

    Anonymous comments are disabled in this journal

    default userpic

    Your reply will be screened

    Your IP address will be recorded 

  • 0 comments