uncon (uncon) wrote in lj_dev,
uncon
uncon
lj_dev

"The Dreaded synsuck wide character bug"

The fix linked below seems to have a problem. The if statement that was added skips over my installation. If if take the statement out, it works fine for me. I may have missed something, but why use "$] < 5.007"? I thought the problem was specific to Digest:MD5. I'm using Perl 5.8 and Digest:MD5 2.20.

http://www.livejournal.com/community/changelog/541595.html
http://zilla.livejournal.org/show_bug.cgi?id=851

EDIT: Actually, I spoke too soon. I am now getting this error: "Wide character in subroutine entry at /home/lj/cgi-bin/ljprotocol.pl line 654." Line 654 of cgi-bin/ljprotocol.pl contains " my $dupsig = Digest::MD5::md5_hex(join('', map { $req->{$_} }"...
Subscribe
  • Post a new comment

    Error

    Anonymous comments are disabled in this journal

    default userpic

    Your reply will be screened

    Your IP address will be recorded 

  • 4 comments