?

Log in

No account? Create an account
August 11th, 2002 - LiveJournal Development — LiveJournal [entries|archive|friends|userinfo]
LiveJournal Development

[ userinfo | livejournal userinfo ]
[ archive | journal archive ]

August 11th, 2002

A diff for custom mood theme ID input on modify_do.bml [Aug. 11th, 2002|07:54 am]
LiveJournal Development

lj_dev

[captainspam]
(This is where these go, right? I apologize if not)

This is based on a suggestion I made earlier. Everyone seemed to think it was a good idea and nobody seemed to shoot it down as bad. But, nobody did it, so I just went ahead. :-)

Briefly, what I suggested was to put an input box in Modify Journal (modify_do.bml) to allow users to easily use other people's custom mood icon sets, granted they know the ID. It would simplify the process of using custom mood icon sets greatly.

So, I grabbed the code and did it myself. modify_do.bml and moodlist.bml are modified.

Possible problems:

  • Semantics. I'm not sure how the text on the page should be phrased, so I went with my best guess.
  • The resulting HTML does not match the style used elsewhere within modify_do.bml and moodlist.bml, but I'm going on the LJ coding guidelines here (<br /> instead of <BR>, etc).
  • It will not complain if the moodthemeid does not exist.


Testing and diffs:

These have been tested on my tiny test server, and they work inasmuch as it seems to modify the database to the same extent as a normal moodthemeid change does. I have no moodthemes in play, so I'm not sure if they'll display right, but in theory, it does the same thing as normal, but with custom numbers, so all should be well.

http://things.exclaimindustries.net/modify_do.bml.diff
http://things.exclaimindustries.net/moodlist.bml.diff

To quote the immortal Joel Hodgson, "Whadya think, sirs?" (Or should I have posted these diffs elsewhere?)
link9 comments|post comment

problem with BML [Aug. 11th, 2002|11:48 am]
LiveJournal Development

lj_dev

[lucretio]
I have a problem setting up BML on my Win32 machine that I posted about in bml.

I'd like to know:
  • what files I need for BML only
  • what needs to be in my httpd.conf
  • what needs to be in my bml(p)(-local).cfg (specifically, what should VarInitScript be?)
(P.S. I know this isn't the right community (bml is), but I don't think anyone who can answer my question is watching bml.)
link8 comments|post comment

Single-entry Friends page bug [Aug. 11th, 2002|01:35 pm]
LiveJournal Development

lj_dev

[bradfitz]
I just wrote a huge post explaining the bug snej reported recently involving friends pages with single entries not reliably showing the right entry.

I explained the current algorithm, where its flaw was, and how we started to fix it 5 months ago, but had to wait for a new table to populate before we finished.

I went to file a zilla bug on it, and include the URL in my lj_dev post.

In the middle of filing it, I pulled my computer's power cable out with my toe or something. (had my foot up on the tower, under my desk)

Anyway,
http://zilla.livejournal.org/show_bug.cgi?id=109
link4 comments|post comment

Installation of LiveJournal code [Aug. 11th, 2002|02:34 pm]
LiveJournal Development

lj_dev

[timwi]
Dearest developers, ;-)

I have installed the LiveJournal source code on my computer and configured Apache, MySQL and Perl accordingly. However, when I try to access the site, I get a "500 Internal Server Error". The error log shows this:

[Sun Aug 11 14:22:13 2002] [error] Undefined subroutine &Apache::LiveJournal::handler called.
[Sun Aug 11 14:22:13 2002] [error] Undefined subroutine &Apache::LiveJournal::handler called.
[Sun Aug 11 14:22:13 2002] [notice] child pid 2838 exit signal Segmentation fault (11)


Does anyone have any idea what might be causing this? Please reply back if you need more information about my setup and configuration and stuff... there's such a lot that I don't know what's important and what isn't.
link18 comments|post comment

Unicode support? [Aug. 11th, 2002|07:17 pm]
LiveJournal Development

lj_dev

[timwi]
I've finally managed to install the LiveJournal server software on my computer. It seems to work fine so far... just one thing is bothering me: It isn't using UTF-8, like www.livejournal.com is. How can I enable that? Thanks in advance.
link4 comments|post comment

navigation
[ viewing | August 11th, 2002 ]
[ go | Previous Day|Next Day ]